[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Sep 10 02:32:04 PDT 2021

mgorny added a comment.

In D108554#2993993 <https://reviews.llvm.org/D108554#2993993>, @labath wrote:

> In D108554#2993830 <https://reviews.llvm.org/D108554#2993830>, @mgorny wrote:
>> In D108554#2993766 <https://reviews.llvm.org/D108554#2993766>, @labath wrote:
>>> I'm not sure we should be preserving this behavior for the native register context. User-provided strings should not make it there, and code should really be retrieving the registers in some other way (like via the LLDB_REGNUM_GENERIC_*** constants).
>> Could you rephrase this comment to indicate the requested change, if any? ;-)
> Well.. the comment was open ended, because my thoughts on this are quite open ended as well.. :) But if I wanted to be more precise, I suppose it boils down to this:
> - Is the NativeRC change there for a particular reason (like, does anything break if you leave it out)?
> - Do _you_ agree with my assessment of its necessity?
> If there's no reason for its presence, and you don't see it as necessary, then I'd like to remove it. If not, let's talk.

Ah, now I get what you mean. To be honest, I've done that because I wasn't sure whether there isn't any code relying on that. I guess I'll try removing it and see if any tests fail.



More information about the lldb-commits mailing list