[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names
Michał Górny via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Fri Sep 10 04:55:10 PDT 2021
mgorny added a comment.
Ok, so I've done some testing and indeed Native* part doesn't seem necessary.
However, after removing the aliases from x86_64 target def, there are two test regressions. The two following snippets no longer seem to work:
eip = frame.FindRegister("pc")
sp_value = frame0.FindValue("sp", lldb.eValueTypeRegister)
This doesn't seem to work anymore. Should I attempt to fix the API to make grabbing these registers by name work again, or should I try to modify the tests to grab these registers via generic reg nums?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108554/new/
https://reviews.llvm.org/D108554
More information about the lldb-commits
mailing list