[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Sep 10 02:28:11 PDT 2021

labath added a comment.

In D108554#2993830 <https://reviews.llvm.org/D108554#2993830>, @mgorny wrote:

> In D108554#2993766 <https://reviews.llvm.org/D108554#2993766>, @labath wrote:
>> I'm not sure we should be preserving this behavior for the native register context. User-provided strings should not make it there, and code should really be retrieving the registers in some other way (like via the LLDB_REGNUM_GENERIC_*** constants).
> Could you rephrase this comment to indicate the requested change, if any? ;-)

Well.. the comment was open ended, because my thoughts on this are quite open ended as well.. :) But if I wanted to be more precise, I suppose it boils down to this:

- Is the NativeRC change there for a particular reason (like, does anything break if you leave it out)?
- Do _you_ agree with my assessment of its necessity?

If there's no reason for its presence, and you don't see it as necessary, then I'd like to remove it. If not, let's talk.

>> It would also be nice to follow this up by actually removing the generic altnames from register definitions, for cases where they don't match architecturally defined names.
> That was roughly my plan, presuming you like the idea. Should I include this in the same commit or separately for each platform?

Sounds good. I think we should do it as a separate patch. Whether it's one or more of them depends on how large they get...



More information about the lldb-commits mailing list