[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Sep 10 01:34:04 PDT 2021

mgorny added a comment.

In D108554#2993766 <https://reviews.llvm.org/D108554#2993766>, @labath wrote:

> I'm not sure we should be preserving this behavior for the native register context. User-provided strings should not make it there, and code should really be retrieving the registers in some other way (like via the LLDB_REGNUM_GENERIC_*** constants).

Could you rephrase this comment to indicate the requested change, if any? ;-)

> It would also be nice to follow this up by actually removing the generic altnames from register definitions, for cases where they don't match architecturally defined names.

That was roughly my plan, presuming you like the idea. Should I include this in the same commit or separately for each platform?



More information about the lldb-commits mailing list