[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Sep 10 01:18:29 PDT 2021


labath added a comment.

I'm not sure we should be preserving this behavior for the native register context. User-provided strings should not make it there, and code should really be retrieving the registers in some other way (like via the LLDB_REGNUM_GENERIC_*** constants).

It would also be nice to follow this up by actually removing the generic altnames from register definitions, for cases where they don't match architecturally defined names.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D108554/new/

https://reviews.llvm.org/D108554



More information about the lldb-commits mailing list