[PATCH] D154363: [mlir] Add an interface to decompose complex ops

Quentin Colombet via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jul 5 03:10:20 PDT 2023


qcolombet marked 9 inline comments as done.
qcolombet added inline comments.


================
Comment at: mlir/lib/Dialect/Linalg/IR/LinalgOps.cpp:2382
+/// }
+static Value computeSoftmax(Value numerator, Value denominator, Value output,
+                            int64_t dim, Location loc, OpBuilder &builder) {
----------------
qcolombet wrote:
> chelini wrote:
> > nit: I think naming is a bit misleading here. Simply, `buildDivOp`?
> Good point.
Forgot to use a free cast here, will fix in a sec.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D154363/new/

https://reviews.llvm.org/D154363



More information about the llvm-commits mailing list