[PATCH] D153162: [dsymutil] Fix .debug_addr index calculation
Jonas Devlieghere via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jun 16 13:58:25 PDT 2023
JDevlieghere marked an inline comment as done.
JDevlieghere added a comment.
In D153162#4429314 <https://reviews.llvm.org/D153162#4429314>, @JDevlieghere wrote:
> In D153162#4429293 <https://reviews.llvm.org/D153162#4429293>, @thakis wrote:
>
>> Seems to break tests: http://45.33.8.238/linux/110001/step_12.txt
>>
>> Please take a look and revert for now if it takes a while to fix.
>
> Working on it, just a matter of updating the tests.
Fixed in 8e1f820bb4ea <https://reviews.llvm.org/rG8e1f820bb4eadf5c0704818f6063e0db1006e32d>.
================
Comment at: llvm/tools/dsymutil/DwarfLinkerForBinary.cpp:1088
+ const uint64_t StartOffset =
+ *AddrOffsetSectionBase + (AddrValue->getRawUValue() * ByteSize);
+ const uint64_t EndOffset = StartOffset + ByteSize;
----------------
aprantl wrote:
> I find the name ByteSize misleading. Would you be okay with renaming it to AddrSize? Then it's consistent with how dwarfdump prints the .debug_addr header.
Done in 8e1f820bb4ea.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D153162/new/
https://reviews.llvm.org/D153162
More information about the llvm-commits
mailing list