[PATCH] D153162: [dsymutil] Fix .debug_addr index calculation
Adrian Prantl via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jun 16 13:49:28 PDT 2023
aprantl added inline comments.
================
Comment at: llvm/tools/dsymutil/DwarfLinkerForBinary.cpp:1088
+ const uint64_t StartOffset =
+ *AddrOffsetSectionBase + (AddrValue->getRawUValue() * ByteSize);
+ const uint64_t EndOffset = StartOffset + ByteSize;
----------------
I find the name ByteSize misleading. Would you be okay with renaming it to AddrSize? Then it's consistent with how dwarfdump prints the .debug_addr header.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D153162/new/
https://reviews.llvm.org/D153162
More information about the llvm-commits
mailing list