[PATCH] D152843: Switch magic numbers to library functions in fixup

Eli Friedman via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jun 13 15:07:43 PDT 2023


efriedma added a comment.

I like using isInt() and isUInt() more.

isShiftedUInt() also checks the low bits, so I think this changes the diagnostic output in some cases?

I don't like `Value != alignTo<4>(Value)`; `alignTo<4>(Value)` doesn't represent any actual relevant value.

Not sure about replacing `0x3ffffff` with `maskTrailingOnes<uint64_t>(26)`; it's really verbose, and the name isn't great.  Maybe if we can come up with some shorter alternative?  Or maybe just write `((1ULL << 26) - 1)`?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D152843/new/

https://reviews.llvm.org/D152843



More information about the llvm-commits mailing list