[PATCH] D142021: AMDGPU/GlobalISel: Add stub custom regbankselect pass

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jan 20 06:26:21 PST 2023


arsenm marked an inline comment as done.
arsenm added inline comments.


================
Comment at: llvm/lib/Target/AMDGPU/AMDGPURegBankSelect.cpp:14
+
+#define DEBUG_TYPE "regbankselect"
+
----------------
rovka wrote:
> Nit: This diverges from AMDGPUInstructionSelector and Legalizer, which both define the DEBUG_TYPE as "amdgpu-blah" directly.
Those should probably use the generic name. Different debug types for the same pass are counterproductive


================
Comment at: llvm/lib/Target/AMDGPU/AMDGPURegBankSelect.h:10
+/// This file declares the targeting of the InstructionSelector class for
+/// AMDGPU.
+//===----------------------------------------------------------------------===//
----------------
Pierre-vh wrote:
> rovka wrote:
> > Update this comment for RegBankSelect instead of InstructionSelector (ditto for the header guard)
> It would be nice to explain why this custom pass is actually needed. If it's a stub then just say it's a stub but it's been added because it makes X or Y possible later for instance;
> Otherwise it's difficult to understand why it's needed and someone might try to remove it later
I'll just drop it because these style comments are useless


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D142021/new/

https://reviews.llvm.org/D142021



More information about the llvm-commits mailing list