[PATCH] D130947: TableGen: Introduce generated getSubRegisterClass function

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 12 05:58:37 PDT 2022


arsenm added inline comments.


================
Comment at: llvm/lib/Target/AMDGPU/SIRegisterInfo.h:281
+  const TargetRegisterClass *
+  getRegClassForOperandReg(const MachineRegisterInfo &MRI,
+                           const MachineOperand &MO) const;
----------------
foad wrote:
> Jus bikeshedding on the name: would `getRegClassForRegOperand` make more sense, or just `getRegClassForOperand`?
It's specifically getting the class of the virtual register in the operand, not the underlying register class implied by the instruction


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D130947/new/

https://reviews.llvm.org/D130947



More information about the llvm-commits mailing list