[PATCH] D130947: TableGen: Introduce generated getSubRegisterClass function
Jay Foad via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Sep 12 06:04:12 PDT 2022
foad added inline comments.
================
Comment at: llvm/lib/Target/AMDGPU/SIRegisterInfo.h:281
+ const TargetRegisterClass *
+ getRegClassForOperandReg(const MachineRegisterInfo &MRI,
+ const MachineOperand &MO) const;
----------------
arsenm wrote:
> foad wrote:
> > Jus bikeshedding on the name: would `getRegClassForRegOperand` make more sense, or just `getRegClassForOperand`?
> It's specifically getting the class of the virtual register in the operand, not the underlying register class implied by the instruction
OK, then I like the current name :)
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D130947/new/
https://reviews.llvm.org/D130947
More information about the llvm-commits
mailing list