[PATCH] D130947: TableGen: Introduce generated getSubRegisterClass function

Jay Foad via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 12 05:57:15 PDT 2022


foad accepted this revision.
foad added a comment.
This revision is now accepted and ready to land.

LGTM, just nits inline.



================
Comment at: llvm/include/llvm/CodeGen/TargetRegisterInfo.h:632
+  /// Return a register class that can be used for a subregister copy from/into
+  /// \p SuperRC at \p Idx.
+  virtual const TargetRegisterClass *
----------------
"SubRegIdx".


================
Comment at: llvm/lib/Target/AMDGPU/SIRegisterInfo.h:281
+  const TargetRegisterClass *
+  getRegClassForOperandReg(const MachineRegisterInfo &MRI,
+                           const MachineOperand &MO) const;
----------------
Jus bikeshedding on the name: would `getRegClassForRegOperand` make more sense, or just `getRegClassForOperand`?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D130947/new/

https://reviews.llvm.org/D130947



More information about the llvm-commits mailing list