[PATCH] D98086: [FileCheck] Fix numeric error propagation

Joel E. Denny via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Mar 15 12:18:30 PDT 2021


jdenny added inline comments.


================
Comment at: llvm/lib/FileCheck/FileCheck.cpp:1376
   }
   for (const auto &VariableDef : NumericVariableDefs) {
     VarCapture VC;
----------------
jhenderson wrote:
> Aside: this is a good example of where `auto` is hurting readability of the code. I can't tell whether `VariableDef` is an `Optional`, or something else with a `getValue()` method below. If it's the former, you could replace `getValue()` with `->` for example.
Perhaps we need a patch that adjusts all such occurrences in this file.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98086/new/

https://reviews.llvm.org/D98086



More information about the llvm-commits mailing list