[PATCH] D97964: [flang][OpenMP] Add semantic check for occurrence of multiple list items in aligned clause for simd directive
Arnamoy B via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Mar 9 13:13:02 PST 2021
arnamoy10 added inline comments.
================
Comment at: flang/lib/Semantics/check-directive-structure.h:208
+ auto FindClauses(C type) {
+ auto it{GetContext().clauseInfo.equal_range(type)};
----------------
clementval wrote:
> kiranchandramohan wrote:
> > Nit: Naming the type here is probably better. Is there an issue?
> +1 to @kiranchandramohan comment.
Do you mean replace `auto`?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D97964/new/
https://reviews.llvm.org/D97964
More information about the llvm-commits
mailing list