[PATCH] D97964: [flang][OpenMP] Add semantic check for occurrence of multiple list items in aligned clause for simd directive

Valentin Clement via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Mar 9 13:16:25 PST 2021


clementval added inline comments.


================
Comment at: flang/lib/Semantics/check-directive-structure.h:208
 
+  auto FindClauses(C type) {
+    auto it{GetContext().clauseInfo.equal_range(type)};
----------------
arnamoy10 wrote:
> clementval wrote:
> > kiranchandramohan wrote:
> > > Nit: Naming the type here is probably better. Is there an issue?
> > +1 to @kiranchandramohan comment. 
> Do you mean replace `auto`?
Yes. 


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D97964/new/

https://reviews.llvm.org/D97964



More information about the llvm-commits mailing list