[PATCH] D97403: [flang] updated character tests to gtest
Tim Keith via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Mar 7 14:52:17 PST 2021
tskeith added a comment.
In general, we've been using ALL_CAPS for template parameters and CamelCase for type names.
================
Comment at: flang/unittests/RuntimeGTest/CharacterTest.cpp:221
+template <typename CHAR>
+using VERIFY_PARAMETER = std::tuple<const CHAR *, const CHAR *, bool, int>;
+
----------------
I suggest: `using VerifyParameter = ...`.
================
Comment at: flang/unittests/RuntimeGTest/CharacterTest.cpp:226
+ std::vector<VERIFY_PARAMETER<char32_t>>>
+ VerifyParameters{{
+ std::make_tuple("abc", "abc", false, 0),
----------------
This should be `verifyParameters`.
It might be more readable to give this type a name if you can come up with a good one.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D97403/new/
https://reviews.llvm.org/D97403
More information about the llvm-commits
mailing list