[PATCH] D48857: Also search BitcodeFiles for exclude-lib symbols
Rui Ueyama via llvm-commits
llvm-commits at lists.llvm.org
Thu Jul 5 12:28:26 PDT 2018
Is that part of our coding standard? In lld, all local variables holding
function-like objects are in CamelCase, not in camelCase.
On Thu, Jul 5, 2018 at 12:05 PM Duncan P. N. Exon Smith via Phabricator <
reviews at reviews.llvm.org> wrote:
> dexonsmith added inline comments.
>
>
> ================
> Comment at: ELF/Driver.cpp:1156
>
> - for (InputFile *File : ObjectFiles)
> + auto markSymbolsInFile = [&](InputFile *File) {
> if (!File->ArchiveName.empty())
> ----------------
> ruiu wrote:
> > We don't need to give a long descriptive name for a local variable whose
> scope is narrow. Also, in LLVM/lld, local variables must be in CamelCase.
> I'd name this just `Visit`.
> > Also, in LLVM/lld, local variables must be in CamelCase.
>
> Given that this is a function-like object, I'd argue for lowerCamelCase
> here.
>
>
> Repository:
> rLLD LLVM Linker
>
> https://reviews.llvm.org/D48857
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20180705/8fad5a0d/attachment.html>
More information about the llvm-commits
mailing list