[PATCH] D47452: [NFC][X86][AArch64] Reorganize/cleanup BZHI test patterns

Simon Pilgrim via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 28 13:19:11 PDT 2018


RKSimon added inline comments.


================
Comment at: test/CodeGen/AArch64/bmi-bzhi.ll:1
+; NOTE: Assertions have been autogenerated by utils/update_llc_test_checks.py
+; RUN: llc -mtriple=aarch64-unknown-linux-gnu < %s | FileCheck %s
----------------
lebedev.ri wrote:
> craig.topper wrote:
> > bmi-bzhi doesn't make sense as a name for AArch64. Those are the names of X86 extensions. Someone familiar with AArch64, but not X86 would have no understanding of that.
> Yes, indeed, i expected that feedback.
> Should both of them be named something like `extract-low-bits.ll` ?
I'm not sure if we gain much from keeping the same filenames on x86 and aarch64 (include a comment in the files pointing to the other target if you think it useful) - on x86 keeping the bmi files together is tidier, I've no opinion on what the aarch64 file should be called.


================
Comment at: test/CodeGen/X86/bmi-bzhi.ll:4
+; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+bmi,-bmi2 < %s | FileCheck %s --check-prefixes=CHECK,CHECK-BMI,CHECK-BMI1
+; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+bmi,+bmi2 < %s | FileCheck %s --check-prefixes=CHECK,CHECK-BMI,CHECK-BMI2
+
----------------
Should we add i686 test coverage for bmi?


================
Comment at: test/CodeGen/X86/bmi.ll:3
 ; RUN: llc < %s -mtriple=x86_64-unknown-unknown -mattr=+bmi | FileCheck %s --check-prefix=CHECK --check-prefix=BMI1
 ; RUN: llc < %s -mtriple=x86_64-unknown-unknown -mattr=+bmi,+bmi2 | FileCheck %s --check-prefix=CHECK --check-prefix=BMI2
 
----------------
Should we add i686 test coverage for bmi?


Repository:
  rL LLVM

https://reviews.llvm.org/D47452





More information about the llvm-commits mailing list