[PATCH] D36560: [llvm-objcopy] Add support for .dynamic, .dynsym, and .dynstr

Jake Ehrlich via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 18 14:22:36 PDT 2017


jakehehrlich updated this revision to Diff 115721.
jakehehrlich added a comment.

1. Changed name of method to getSectionOfType
2. Fixed typos


Repository:
  rL LLVM

https://reviews.llvm.org/D36560

Files:
  test/tools/llvm-objcopy/Inputs/dynamic.so
  test/tools/llvm-objcopy/Inputs/dynsym.so
  test/tools/llvm-objcopy/dynamic.test
  test/tools/llvm-objcopy/dynstr.test
  test/tools/llvm-objcopy/dynsym.test
  tools/llvm-objcopy/Object.cpp
  tools/llvm-objcopy/Object.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D36560.115721.patch
Type: text/x-patch
Size: 13044 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170918/a3881b7b/attachment-0001.bin>


More information about the llvm-commits mailing list