[PATCH] D25583: Timer: Track Name and Description.

Matthias Braun via llvm-commits llvm-commits at lists.llvm.org
Thu Oct 13 16:36:24 PDT 2016


MatzeB added a comment.

Thanks for the review, yes I have a clang patch as well.



================
Comment at: lib/IR/LegacyPassManager.cpp:452
   // Use 'create' member to get this.
-  TimingInfo() : TG("... Pass execution timing report ...") {}
+  TimingInfo() : TG("pass", "... Pass execution timing report ...") {}
 
----------------
vsk wrote:
> Bikeshed: maybe "timing_info" for the name here? (I don't have a hard '-1' to just keeping "pass".)
This will result in names like: `time.pass.Loop Versioning` which I find nicer than `time.timing_info.Loop Versioning`, don't you think?
(This also shows that unfortunately our pass "names" have the same problem that they are more like descriptions, but as far as I see it that problem will solve itself once the new pass manager has landed which will use the class names of the passes).


================
Comment at: lib/Support/Timer.cpp:214
 static ManagedStatic<Name2PairMap> NamedGroupedTimers;
 
+NamedRegionTimer::NamedRegionTimer(StringRef Name, StringRef Description,
----------------
vsk wrote:
> getNamedRegionTimer has no coverage -- it looks safe to delete in a prep commit.
Yes that is https://reviews.llvm.org/D25582 (some bits of that are visible here as well).


Repository:
  rL LLVM

https://reviews.llvm.org/D25583





More information about the llvm-commits mailing list