[PATCH] D25583: Timer: Track Name and Description.

Vedant Kumar via llvm-commits llvm-commits at lists.llvm.org
Thu Oct 13 16:53:59 PDT 2016


vsk added a comment.

Could you either delete Timer::getName(), or audit it / upgrade its uses? There is no coverage for it either, so it can probably go along with getNamedRegionTimer.

It looks like this patch is NFCI, but it might help to have some kind of test that ensures getName() and getDescription() return something reasonable. Maybe in unittests/Support/TimerTests?



================
Comment at: lib/IR/LegacyPassManager.cpp:452
   // Use 'create' member to get this.
-  TimingInfo() : TG("... Pass execution timing report ...") {}
+  TimingInfo() : TG("pass", "... Pass execution timing report ...") {}
 
----------------
MatzeB wrote:
> vsk wrote:
> > Bikeshed: maybe "timing_info" for the name here? (I don't have a hard '-1' to just keeping "pass".)
> This will result in names like: `time.pass.Loop Versioning` which I find nicer than `time.timing_info.Loop Versioning`, don't you think?
> (This also shows that unfortunately our pass "names" have the same problem that they are more like descriptions, but as far as I see it that problem will solve itself once the new pass manager has landed which will use the class names of the passes).
Sure. I had missed the 'time.' prefix.


Repository:
  rL LLVM

https://reviews.llvm.org/D25583





More information about the llvm-commits mailing list