[PATCH] D17830: [MBP] Avoid placing random blocks between loop preheader and header

Xinliang David Li via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 2 16:52:32 PST 2016


Ok -- the word loop should probably be replaced with something like
'region' (cyclic or acyclic), but that is a different topic.

David

On Wed, Mar 2, 2016 at 4:47 PM, Philip Reames <listmail at philipreames.com>
wrote:

> I'm am specifically trying to avoid any mention of loops because the
> variable is used when not in any loop.
>
> Philip
>
>
> On 03/02/2016 04:45 PM, Xinliang David Li wrote:
>
> Or perhaps UnscheduledPredInLoop ?
>
> David
>
> On Wed, Mar 2, 2016 at 4:08 PM, Philip Reames <listmail at philipreames.com>
> wrote:
>
>> reames added inline comments.
>>
>> ================
>> Comment at: lib/CodeGen/MachineBlockPlacement.cpp:210
>> @@ -209,3 +209,3 @@
>>    /// in-loop predecessors of this chain.
>>    unsigned LoopPredecessors;
>>  };
>> ----------------
>> congh wrote:
>> > chandlerc wrote:
>> > > reames wrote:
>> > > > As a side note, the name of this variable is highly misleading.
>> When scheduling function chains, this is used to track unscheduled
>> predecessors outside of any loop.  Once this change is in, I'd like to
>> rename this to something more meaningful.  Any suggestions?
>> > > No real idea. =/ I agree, it was bad when it started and it has
>> gotten worse.
>> > Maybe ChainPredecessors? But in loops this may also be misleading. If
>> we treat the function as a loop body, maybe ChainPredecessorsInLoop is
>> better?
>> How does UnscheduledPredecessors sound?  I'm going for something that
>> describes how the value changes over time and what that actually means.
>>
>>
>> Repository:
>>   rL LLVM
>>
>> http://reviews.llvm.org/D17830
>>
>>
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160302/bccb3d18/attachment.html>


More information about the llvm-commits mailing list