<div dir="ltr">Ok -- the word loop should probably be replaced with something like 'region' (cyclic or acyclic), but that is a different topic.<div><br></div><div>David</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Mar 2, 2016 at 4:47 PM, Philip Reames <span dir="ltr"><<a href="mailto:listmail@philipreames.com" target="_blank">listmail@philipreames.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
  
    
  
  <div text="#000000" bgcolor="#FFFFFF">
    I'm am specifically trying to avoid any mention of loops because the
    variable is used when not in any loop.<span class="HOEnZb"><font color="#888888"><br>
    <br>
    Philip</font></span><div><div class="h5"><br>
    <br>
    <div>On 03/02/2016 04:45 PM, Xinliang David
      Li wrote:<br>
    </div>
    <blockquote type="cite">
      <div dir="ltr">Or perhaps UnscheduledPredInLoop ?
        <div><br>
        </div>
        <div>David</div>
      </div>
      <div class="gmail_extra"><br>
        <div class="gmail_quote">On Wed, Mar 2, 2016 at 4:08 PM, Philip
          Reames <span dir="ltr"><<a href="mailto:listmail@philipreames.com" target="_blank">listmail@philipreames.com</a>></span>
          wrote:<br>
          <blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">reames
            added inline comments.<br>
            <span><br>
              ================<br>
              Comment at: lib/CodeGen/MachineBlockPlacement.cpp:210<br>
              @@ -209,3 +209,3 @@<br>
                 /// in-loop predecessors of this chain.<br>
                 unsigned LoopPredecessors;<br>
               };<br>
              ----------------<br>
            </span><span>congh wrote:<br>
              > chandlerc wrote:<br>
              > > reames wrote:<br>
              > > > As a side note, the name of this variable
              is highly misleading.  When scheduling function chains,
              this is used to track unscheduled predecessors outside of
              any loop.  Once this change is in, I'd like to rename this
              to something more meaningful.  Any suggestions?<br>
              > > No real idea. =/ I agree, it was bad when it
              started and it has gotten worse.<br>
              > Maybe ChainPredecessors? But in loops this may also
              be misleading. If we treat the function as a loop body,
              maybe ChainPredecessorsInLoop is better?<br>
            </span>How does UnscheduledPredecessors sound?  I'm going
            for something that describes how the value changes over time
            and what that actually means.<br>
            <div>
              <div><br>
                <br>
                Repository:<br>
                  rL LLVM<br>
                <br>
                <a href="http://reviews.llvm.org/D17830" rel="noreferrer" target="_blank">http://reviews.llvm.org/D17830</a><br>
                <br>
                <br>
                <br>
              </div>
            </div>
          </blockquote>
        </div>
        <br>
      </div>
    </blockquote>
    <br>
  </div></div></div>

</blockquote></div><br></div>