[PATCH] D9151: Loop Versioning for LICM
Hal Finkel via llvm-commits
llvm-commits at lists.llvm.org
Wed Feb 3 04:23:11 PST 2016
hfinkel added inline comments.
================
Comment at: lib/Transforms/Scalar/LoopVersioningLICM.cpp:633
@@ +632,3 @@
+INITIALIZE_PASS_DEPENDENCY(LoopInfoWrapperPass)
+INITIALIZE_PASS_DEPENDENCY(LoopSimplify)
+INITIALIZE_PASS_DEPENDENCY(ScalarEvolutionWrapperPass)
----------------
ashutosh.nema wrote:
> hfinkel wrote:
> > No, please rename the other option (as I noted by the other option, putting adding enable- as a prefix would be natural). Then make this change.
> I did not understood this comment completely.
>
> Are you saying use "enable-loop-versioning-licm" here, in DEBUG_TYPE & in PassManagerBuilder ?
Use "enable-loop-versioning-licm" in PassManagerBuilder, and then use "loop-versioning-licm" in DEBUG_TYPE and here. Thanks!
Repository:
rL LLVM
http://reviews.llvm.org/D9151
More information about the llvm-commits
mailing list