[PATCH] D9151: Loop Versioning for LICM
Nema, Ashutosh via llvm-commits
llvm-commits at lists.llvm.org
Wed Feb 3 05:15:01 PST 2016
Thanks Hal for clarification, will make these changes and come back.
Regards,
Ashutosh
-----Original Message-----
From: Hal Finkel [mailto:hfinkel at anl.gov]
Sent: Wednesday, February 03, 2016 5:53 PM
To: Nema, Ashutosh; anemet at apple.com; hfinkel at anl.gov; listmail at philipreames.com; charlie.turner at arm.com
Cc: matze at braunis.de; tobias at grosser.es; mehdi.amini at apple.com; sanjoy at playingwithpointers.com; javed.absar at arm.com; silviu.baranga at arm.com; llvm-commits at lists.llvm.org
Subject: Re: [PATCH] D9151: Loop Versioning for LICM
hfinkel added inline comments.
================
Comment at: lib/Transforms/Scalar/LoopVersioningLICM.cpp:633
@@ +632,3 @@
+INITIALIZE_PASS_DEPENDENCY(LoopInfoWrapperPass)
+INITIALIZE_PASS_DEPENDENCY(LoopSimplify)
+INITIALIZE_PASS_DEPENDENCY(ScalarEvolutionWrapperPass)
----------------
ashutosh.nema wrote:
> hfinkel wrote:
> > No, please rename the other option (as I noted by the other option, putting adding enable- as a prefix would be natural). Then make this change.
> I did not understood this comment completely.
>
> Are you saying use "enable-loop-versioning-licm" here, in DEBUG_TYPE & in PassManagerBuilder ?
Use "enable-loop-versioning-licm" in PassManagerBuilder, and then use "loop-versioning-licm" in DEBUG_TYPE and here. Thanks!
Repository:
rL LLVM
http://reviews.llvm.org/D9151
More information about the llvm-commits
mailing list