[PATCH] D9151: Loop Versioning for LICM
Ashutosh Nema via llvm-commits
llvm-commits at lists.llvm.org
Tue Feb 2 22:34:20 PST 2016
ashutosh.nema added a comment.
Thanks Hal.
I'll work on your comments and come back.
================
Comment at: lib/Transforms/Scalar/LoopVersioningLICM.cpp:633
@@ +632,3 @@
+INITIALIZE_PASS_DEPENDENCY(LoopInfoWrapperPass)
+INITIALIZE_PASS_DEPENDENCY(LoopSimplify)
+INITIALIZE_PASS_DEPENDENCY(ScalarEvolutionWrapperPass)
----------------
hfinkel wrote:
> No, please rename the other option (as I noted by the other option, putting adding enable- as a prefix would be natural). Then make this change.
I did not understood this comment completely.
Are you saying use "enable-loop-versioning-licm" here, in DEBUG_TYPE & in PassManagerBuilder ?
Repository:
rL LLVM
http://reviews.llvm.org/D9151
More information about the llvm-commits
mailing list