[PATCH] Kill the LLVM global lock

Zachary Turner zturner at google.com
Tue Jun 17 14:14:36 PDT 2014


Thanks!  Will wait for Chandler's lgtm as well before I push, since he's
had a bunch of comments on past iterations, want to make sure all of his
concerns are addressed as well.


On Tue, Jun 17, 2014 at 2:06 PM, Reid Kleckner <rnk at google.com> wrote:

> lgtm
>
> ================
> Comment at: lib/Support/ManagedStatic.cpp:32
> @@ +31,3 @@
> +// static initialization, so roll our own.
> +static std::recursive_mutex& GetManagedStaticMutex() {
> +  std::call_once(MutexInitializationFlag,
> ----------------
> The new function naming convention is camelCase over StudlyCaps:
>
> http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly
>
> The confusion is understandable, because the existing code is very
> inconsistent.
>
> http://reviews.llvm.org/D4142
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20140617/38908cb4/attachment.html>


More information about the llvm-commits mailing list