[PATCH] Kill the LLVM global lock
Reid Kleckner
rnk at google.com
Tue Jun 17 14:06:58 PDT 2014
lgtm
================
Comment at: lib/Support/ManagedStatic.cpp:32
@@ +31,3 @@
+// static initialization, so roll our own.
+static std::recursive_mutex& GetManagedStaticMutex() {
+ std::call_once(MutexInitializationFlag,
----------------
The new function naming convention is camelCase over StudlyCaps:
http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly
The confusion is understandable, because the existing code is very inconsistent.
http://reviews.llvm.org/D4142
More information about the llvm-commits
mailing list