[llvm-commits] PATCH: Refactored hashing for constant unique map

Talin viridia at gmail.com
Sun Feb 5 16:49:05 PST 2012


Done.

On Sun, Feb 5, 2012 at 4:43 PM, Jakob Stoklund Olesen <stoklund at 2pi.dk>wrote:

>
> On Feb 5, 2012, at 4:31 PM, Talin wrote:
>
> > Patch to refactor the hashing functions for the constant unique map, to
> avoid code duplication.
>
> Wouldn't it give nicer code if you kept the intermediate state as a class
> member?
>
> Something like:
>
> IncrementalHash Hash
> Hash.add(foo);
> Hahs.add(bar);
> return Hash.finish();
>
> /jakob
>
>


-- 
-- Talin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120205/084079b5/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hashing.patch
Type: application/octet-stream
Size: 4605 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120205/084079b5/attachment.obj>


More information about the llvm-commits mailing list