[llvm-commits] PATCH: Refactored hashing for constant unique map

Talin viridia at gmail.com
Sun Feb 5 16:52:17 PST 2012


Oops, here's the correct patch.

On Sun, Feb 5, 2012 at 4:49 PM, Talin <viridia at gmail.com> wrote:

> Done.
>
>
> On Sun, Feb 5, 2012 at 4:43 PM, Jakob Stoklund Olesen <stoklund at 2pi.dk>wrote:
>
>>
>> On Feb 5, 2012, at 4:31 PM, Talin wrote:
>>
>> > Patch to refactor the hashing functions for the constant unique map, to
>> avoid code duplication.
>>
>> Wouldn't it give nicer code if you kept the intermediate state as a class
>> member?
>>
>> Something like:
>>
>> IncrementalHash Hash
>> Hash.add(foo);
>> Hahs.add(bar);
>> return Hash.finish();
>>
>> /jakob
>>
>>
>
>
> --
> -- Talin
>



-- 
-- Talin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120205/4d669354/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hashing.patch
Type: application/octet-stream
Size: 4580 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120205/4d669354/attachment.obj>


More information about the llvm-commits mailing list