[llvm-commits] PATCH: Refactored hashing for constant unique map

Jakob Stoklund Olesen stoklund at 2pi.dk
Sun Feb 5 16:43:58 PST 2012


On Feb 5, 2012, at 4:31 PM, Talin wrote:

> Patch to refactor the hashing functions for the constant unique map, to avoid code duplication.

Wouldn't it give nicer code if you kept the intermediate state as a class member?

Something like:

IncrementalHash Hash
Hash.add(foo);
Hahs.add(bar);
return Hash.finish();

/jakob





More information about the llvm-commits mailing list