[llvm-commits] [PATCH] Allow Module deletion after function compiled.

Evan Cheng evan.cheng at apple.com
Fri Oct 23 12:45:31 PDT 2009


Looks good.

+    static void onDeleted(ExecutionEngineState *EES, const  
GlobalValue *Old);
It seems like "onDelete" is a better name? It's more consistent with  
onRAUW.

+    {
+      raw_string_ostream os(errMsg);
+      Error.Print("", os);
+    }

Not important. But why the { }?

Thanks,

Evan

On Oct 22, 2009, at 3:43 PM, jyasskin at gmail.com wrote:

> Evan, could you take a look?
>
> New patch at
> http://codereview.appspot.com/download/issue133043_3001.diff
>
> http://codereview.appspot.com/133043

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20091023/2bbd97c6/attachment.html>


More information about the llvm-commits mailing list