[llvm-commits] [PATCH] Allow Module deletion after function compiled.

Jeffrey Yasskin jyasskin at google.com
Fri Oct 23 15:32:37 PDT 2009


On Fri, Oct 23, 2009 at 12:45 PM, Evan Cheng <evan.cheng at apple.com> wrote:
> Looks good.
>
> +    static void onDeleted(ExecutionEngineState *EES, const GlobalValue
> *Old);
>
> It seems like "onDelete" is a better name? It's more consistent with onRAUW.

Changed in r84967. Thanks.

> +    {
> +      raw_string_ostream os(errMsg);
> +      Error.Print("", os);
> +    }
>
> Not important. But why the { }?

To make sure the ostream gets flushed. But I could call flush
explicitly or use .str(), and it'd take fewer lines. Changed.

Thanks for the review!

> Thanks,
> Evan
> On Oct 22, 2009, at 3:43 PM, jyasskin at gmail.com wrote:
>
> Evan, could you take a look?
>
> New patch at
> http://codereview.appspot.com/download/issue133043_3001.diff
>
> http://codereview.appspot.com/133043
>
>
> _______________________________________________
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits
>
>



More information about the llvm-commits mailing list