[Lldb-commits] [PATCH] D109626: [lldb] Remove redundant register alt_names

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Sep 10 13:09:42 PDT 2021


mgorny created this revision.
mgorny added reviewers: labath, krytarowski, emaste.
Herald added subscribers: atanasyan, jrtc27, kbarton, kristof.beyls, nemanjai, sdardis.
mgorny requested review of this revision.

Remove redundant register alt_names that correspond to their respective
generic names.  D108554 <https://reviews.llvm.org/D108554> makes it possible to query registers through
their generic names directly, therefore making repeating them via
alt_name unnecessary.

While at it, also remove alt_names that are equal to register names
on PPC.

This patch does not alter register definitions where the generic names
are listed as primary names, and other names are provided as alt_name
(e.g. ARM).


https://reviews.llvm.org/D109626

Files:
  lldb/source/Plugins/ABI/ARM/ABIMacOSX_arm.cpp
  lldb/source/Plugins/ABI/ARM/ABISysV_arm.cpp
  lldb/source/Plugins/ABI/Mips/ABISysV_mips.cpp
  lldb/source/Plugins/ABI/Mips/ABISysV_mips64.cpp
  lldb/source/Plugins/ABI/PowerPC/ABISysV_ppc.cpp
  lldb/source/Plugins/ABI/SystemZ/ABISysV_s390x.cpp
  lldb/source/Plugins/Process/Utility/RegisterContextWindows_x86_64.cpp
  lldb/source/Plugins/Process/Utility/RegisterInfos_powerpc.h
  lldb/source/Plugins/Process/Utility/RegisterInfos_ppc64.h
  lldb/source/Plugins/Process/Utility/RegisterInfos_ppc64le.h
  lldb/source/Plugins/Process/Utility/RegisterInfos_s390x.h
  lldb/source/Plugins/Process/Utility/RegisterInfos_x86_64.h
  lldb/source/Plugins/Process/gdb-remote/GDBRemoteRegisterContext.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D109626.371996.patch
Type: text/x-patch
Size: 37060 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20210910/c1e37672/attachment-0001.bin>


More information about the lldb-commits mailing list