[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names
Michał Górny via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Fri Sep 10 09:39:59 PDT 2021
mgorny updated this revision to Diff 371941.
mgorny added a comment.
Fixed `SBFrame` stuffs. While at it, changed `ValueObjectRegister` to take `const RegisterInfo *` instead of the index, since it's almost always what it really wants.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108554/new/
https://reviews.llvm.org/D108554
Files:
lldb/include/lldb/Core/ValueObjectRegister.h
lldb/source/API/SBFrame.cpp
lldb/source/Core/ValueObjectRegister.cpp
lldb/source/Target/RegisterContext.cpp
lldb/test/API/functionalities/gdb_remote_client/TestGDBServerTargetXML.py
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D108554.371941.patch
Type: text/x-patch
Size: 11778 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20210910/02f2181b/attachment-0001.bin>
More information about the lldb-commits
mailing list