[libcxx-commits] [PATCH] D155258: [libc++] Granulaize math.h and move the functions to std::__math
Nikolas Klauser via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Fri Jul 14 10:12:38 PDT 2023
philnik added inline comments.
================
Comment at: libcxx/include/__math/remainder.h:10
+#ifndef _LIBCPP___MATH_REMAINDER_H
+#define _LIBCPP___MATH_REMAINDER_H
+
----------------
Mordante wrote:
> Nit: since the file contains modulo to, how about naming the file `math_division.h` instead or move the modulo to its own file.
I think moving the modules to their own file sounds good.
================
Comment at: libcxx/test/std/depr/depr.c.headers/math_h.pass.cpp:10
+// Clang complains that fabs is called with an integer
+// ADDITIONAL_COMPILE_FLAGS: -Wno-absolute-value
+
----------------
Mordante wrote:
> Why is this needed, can you mention this in the commit message?
I'll check again whether it's actually needed. This might just be a leftover from trying to fix something. (I suspect it's not actually needed)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D155258/new/
https://reviews.llvm.org/D155258
More information about the libcxx-commits
mailing list