[cfe-users] segmentation fault 11 when running clang-tidy

Hongping Lim via cfe-users cfe-users at lists.llvm.org
Mon Jan 11 17:57:44 PST 2016

I am on Mac OS X 10.11.1, and downloaded the sources and followed the
instructions to build clang-tidy. I used xcodebuild and xcpretty to
generate the compile_commands.json file. I have the json file in my project
root, and ran:

~/build/bin/clang-tidy ./MyFile.m

Initially I got this error "LLVM ERROR: unknown module format", and after
some Googling, tried to delete all the fmodule and gmodule parameters from
the json file.

After that, I keep getting "Segmentation fault: 11" most of the time. There
was once when I was able to get the list of warnings, but when I run the
same command right after, I get the segmentation fault again.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-users/attachments/20160111/8dd9f0c3/attachment.html>

More information about the cfe-users mailing list