[PATCH] D134337: [clang] [Driver] More flexible rules for loading default configs

Serge Pavlov via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Sep 28 01:23:34 PDT 2022


sepavloff added inline comments.


================
Comment at: clang/docs/ReleaseNotes.rst:236-239
+- Clang now supports loading multiple configuration files. The files from
+  default configuration paths are loaded first, unless ``--no-default-config``
+  option is used. All files explicitly specified using ``--config`` option
+  are loaded afterwards.
----------------
mgorny wrote:
> sepavloff wrote:
> > I would say this paragraph is a combination of two provided below. IMHO.
> Yeah, it was intentional. I was thinking it would be cleaner to describe this in tandem but I won't insist. Just please confirm whether I should remove it or keep it.
No, I don't insist. It is OK.


================
Comment at: clang/lib/Driver/Driver.cpp:1089
+
+  bool ModeSuffixUnique = !ClangNameParts.ModeSuffix.empty() &&
+                          ClangNameParts.ModeSuffix != RealMode.str();
----------------
mgorny wrote:
> sepavloff wrote:
> > Can the variable name be better? It looks like it means that driver mode is replaced (overridden).
> Can you suggest a better name? It's used to avoid searching for the same filename twice.
DriverModeReplaced? Or something like that.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D134337/new/

https://reviews.llvm.org/D134337



More information about the cfe-commits mailing list