[PATCH] D93446: [RISCV] Add vadd with mask and without mask builtin.
Craig Topper via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Tue Feb 9 13:22:25 PST 2021
craig.topper added inline comments.
================
Comment at: clang/lib/Basic/Targets/RISCV.cpp:89
+#define BUILTIN(ID, TYPE, ATTRS) \
+ {"__builtin_rvv_" #ID, TYPE, ATTRS, nullptr, ALL_LANGUAGES, nullptr},
+#include "clang/Basic/BuiltinsRISCV.def"
----------------
khchen wrote:
> Jim wrote:
> > Builtins for other extension don't have "__builtin_rvv_" prefix.
> maybe we could rename BuiltinsRISCV.def as BuiltinsRVV.def, and other extension defines their own .def file?
>
> @Jim do you have any suggestion?
Don't most targets pass the full name with the prefix to the BUILTIN macro?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D93446/new/
https://reviews.llvm.org/D93446
More information about the cfe-commits
mailing list