[PATCH] D86671: [clang-tidy] Add new case type to check variables with Hungarian notation

Douglas Chen via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Aug 28 09:14:46 PDT 2020


dougpuob marked 2 inline comments as not done.
dougpuob added inline comments.


================
Comment at: clang-tools-extra/clang-tidy/bugprone/ReservedIdentifierCheck.h:44
   llvm::Optional<FailureInfo>
-  GetDeclFailureInfo(const StringRef &TypeName, const NamedDecl *Decl,
+  getDeclFailureInfo(const StringRef &TypeName, const NamedDecl *Decl,
                      const SourceManager &SM) const override;
----------------
aaron.ballman wrote:
> Given that the other functions in the class use the wrong style of casing, we should probably leave this declaration alone so it doesn't become locally inconsistent.
Do you mean create another function with three parameters for it?


================
Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:428
 
   case IdentifierNamingCheck::CT_HungarianNotation: {
     const NamedDecl *pNamedDecl = dyn_cast<NamedDecl>(pDecl);
----------------
njames93 wrote:
> aaron.ballman wrote:
> > I feel like I must be missing something because I don't have this enum in my copy of ToT despite pulling this morning. Is the patch missing some content?
> I feel like this is an incremental diff based on the first version of this patch rather than a diff from trunk. 
@aaron.ballman and @njames93, the diff is based on first version not from master(trunk).

Is it the best way that I should merge with the latest master(trunk) every time before updating the diffs ?


Repository:
  rCTE Clang Tools Extra

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D86671/new/

https://reviews.llvm.org/D86671



More information about the cfe-commits mailing list