[PATCH] D86671: [clang-tidy] Add new case type to check variables with Hungarian notation
Aaron Ballman via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Aug 28 07:46:36 PDT 2020
aaron.ballman added inline comments.
================
Comment at: clang-tools-extra/clang-tidy/bugprone/ReservedIdentifierCheck.h:44
llvm::Optional<FailureInfo>
- GetDeclFailureInfo(const StringRef &TypeName, const NamedDecl *Decl,
+ getDeclFailureInfo(const StringRef &TypeName, const NamedDecl *Decl,
const SourceManager &SM) const override;
----------------
Given that the other functions in the class use the wrong style of casing, we should probably leave this declaration alone so it doesn't become locally inconsistent.
================
Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:428
case IdentifierNamingCheck::CT_HungarianNotation: {
const NamedDecl *pNamedDecl = dyn_cast<NamedDecl>(pDecl);
----------------
I feel like I must be missing something because I don't have this enum in my copy of ToT despite pulling this morning. Is the patch missing some content?
================
Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.h:69
llvm::Optional<FailureInfo>
- GetDeclFailureInfo(const StringRef &Type, const NamedDecl *Decl,
+ getDeclFailureInfo(const StringRef &Type, const NamedDecl *Decl,
const SourceManager &SM) const override;
----------------
Same here.
================
Comment at: clang-tools-extra/clang-tidy/utils/RenamerClangTidyCheck.h:127
virtual llvm::Optional<FailureInfo>
- GetDeclFailureInfo(const StringRef &Type, const NamedDecl *Decl,
+ getDeclFailureInfo(const StringRef &Type, const NamedDecl *Decl,
const SourceManager &SM) const = 0;
----------------
And same here.
Repository:
rCTE Clang Tools Extra
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D86671/new/
https://reviews.llvm.org/D86671
More information about the cfe-commits
mailing list