[PATCH] D80222: Replace Clang's createRuntimeFunction with the definitions in OMPKinds.def

Joseph Huber via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu May 21 11:54:07 PDT 2020


jhuber6 marked 2 inline comments as done.
jhuber6 added inline comments.


================
Comment at: llvm/include/llvm/Frontend/OpenMP/OMPIRBuilder.h:203
+  static Function *getOrCreateRuntimeFunction(Module &Md,
+                                              omp::RuntimeFunction FnID);
 
----------------
jdoerfert wrote:
> jhuber6 wrote:
> > jdoerfert wrote:
> > > Nit: M is the commonly used name for a module ;)
> > The OpenMPIRBuilder struct has a Module named M so I wasn't sure if I should be shadowing it.
> Go with `M`, it's static :)
Forgot to write the file when I changed it here, not work updating the diff for a single character. I'll put it in the next one.


================
Comment at: llvm/include/llvm/Frontend/OpenMP/OMPKinds.def:244
 
-// TODO: Replace this with the real size_t type
-#define __OMP_SIZE_TYPE(NAME) OMP_TYPE(NAME, Type::getInt64Ty(Ctx))
+#define __OMP_SIZE_TYPE(NAME) OMP_TYPE(NAME, M.getDataLayout().getIntPtrType(Ctx))
 __OMP_SIZE_TYPE(SizeTy)
----------------
I'm just directly getting the SizeTy from the Module, I'm not sure if this is a permanent solution.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80222/new/

https://reviews.llvm.org/D80222





More information about the cfe-commits mailing list