[PATCH] D57238: [AST][NFC] Various cleanups to GenericSelectionExpr

Aaron Ballman via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Jan 25 06:36:56 PST 2019


aaron.ballman accepted this revision.
aaron.ballman added a comment.
This revision is now accepted and ready to land.

LGTM!



================
Comment at: include/clang/AST/Expr.h:5095
+
+  Expr *getAssocExpr(unsigned i) {
+    return cast<Expr>(SubExprs[AssocExprStartIndex + i]);
----------------
If you wanted to fix up `i` to be `Idx` or something more closely matching the naming conventions, that would be a nice change. Same elsewhere in the patch.


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57238/new/

https://reviews.llvm.org/D57238





More information about the cfe-commits mailing list