[all-commits] [llvm/llvm-project] 7eb73b: [CIR] Cleanup: mlirContext and astContext (#119450)

David Olsen via All-commits all-commits at lists.llvm.org
Tue Dec 10 13:46:30 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 7eb73b95cb336cde14d5c755a09cd880bd3d5df9
      https://github.com/llvm/llvm-project/commit/7eb73b95cb336cde14d5c755a09cd880bd3d5df9
  Author: David Olsen <dolsen at nvidia.com>
  Date:   2024-12-10 (Tue, 10 Dec 2024)

  Changed paths:
    M clang/include/clang/CIR/CIRGenerator.h
    M clang/lib/CIR/CodeGen/CIRGenModule.cpp
    M clang/lib/CIR/CodeGen/CIRGenModule.h
    M clang/lib/CIR/CodeGen/CIRGenTypes.cpp
    M clang/lib/CIR/CodeGen/CIRGenTypes.h
    M clang/lib/CIR/CodeGen/CIRGenerator.cpp

  Log Message:
  -----------
  [CIR] Cleanup: mlirContext and astContext (#119450)

ClangIR CodeGen code uses both `mlir::MLIRContext` and
`clang::ASTContext` objects extensively. Refering to either of those as
just "context" can be confusing.

Change the names of all variables, parameters, and fields in
`clang/lib/CIR/CodeGen` that refer to `MLIRContext` or an `ASTContext`
to be either `mlirContext` or `astContext`.

This change is only the renaming of variables/parameters/fields. There
are no behavior changes. So there are no new tests or changes to
existing tests. This change mimics a recent change in the ClangIR
incubator repository.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list