[all-commits] [llvm/llvm-project] 54150e: [libc++][NFC] Refactor enable_ifs in vector
philnik777 via All-commits
all-commits at lists.llvm.org
Tue Sep 20 01:06:52 PDT 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 54150e8257e462290e8f43f3a4153d12fb778216
https://github.com/llvm/llvm-project/commit/54150e8257e462290e8f43f3a4153d12fb778216
Author: Nikolas Klauser <nikolasklauser at berlin.de>
Date: 2022-09-20 (Tue, 20 Sep 2022)
Changed paths:
M libcxx/include/vector
Log Message:
-----------
[libc++][NFC] Refactor enable_ifs in vector
Using the `enable_if_t<..., int> = 0` style has the benefit that it works in all cases and makes function declarations easier to read because the function arguments and return type and SFINAE are separated. Unifying the style also makes it easier for people not super familiar with SFINAE to make sense of the code.
Reviewed By: Mordante, var-const, #libc, huixie90
Spies: huixie90, libcxx-commits
Differential Revision: https://reviews.llvm.org/D131868
More information about the All-commits
mailing list