[llvm-dev] Unable to build and install LLVM on Mac OSX 10.11

Mehdi Amini via llvm-dev llvm-dev at lists.llvm.org
Thu Jun 9 08:57:22 PDT 2016


Building on OS X with Xcode is well tested: http://lab.llvm.org:8080/green/

What does `xcrun clang -v` returns on your system?
What is your cmake command line?

Starting simple I'd expect this sequence of command to work:

git clone http://llvm.org/git/llvm.git 
mkdir build
cd build
xcrun cmake ../llvm

If this does not work, please post more information on what failure do you see.

Another good way to reproduce the tested configuration is to look at the log on the bots and use the same cmake args: http://lab.llvm.org:8080/green/job/clang-stage1-cmake-RA-incremental_build/25897/console


> On Jun 9, 2016, at 3:48 AM, Sumedh Arani via llvm-dev <llvm-dev at lists.llvm.org> wrote:
> Greetings dear developers!!
> I've been faced with several difficulties yet I'm unable to do a complete build of LLVM on my system.
> I've tried to build with Xcode once, ninja + cmake, and several other ways as shown in the web.
> Currently, while building on Xcode for the umpteenth time I got an error which says outdated version of svn being used and then architecture not supported.
> When using ninja or make to complete the install, it ends with prompt saying that it ended in a fatal error and the header file  <stdio.h> couldn't be found.
> I've tried building the same several times.
> I've 4gb ram with an i5 processor and running the latest OSX on my macintosh.
> I've tried most of the solutions stated in the web.
> Can anyone help me with regarding the same. with a detailed instruction set as to how to go about getting the build complete properly.
> Thank you.
> Yours sincerely,
> Sumedh Arani.
> _______________________________________________
> LLVM Developers mailing list
> llvm-dev at lists.llvm.org
> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev

More information about the llvm-dev mailing list