[LLVMdev] LLVMdev Digest, Vol 85, Issue 50
rjmccall at apple.com
Wed Jul 27 11:31:07 PDT 2011
On Jul 27, 2011, at 11:17 AM, Chris Lattner wrote:
> On Jul 27, 2011, at 11:10 AM, John McCall wrote:
>>> 6) it would be nice if the existing UnwindInst could be retained. I wince at naming an instruction
>>> "Resume" since in the English language it is so ambiguous (resume normal execution following
>>> the conclusion of handing an exception, verses resume throwing an exception). IE cosmetics
>>> do matter.
>> I would be fine with still calling resume "unwind", but the new instruction
>> does need to carry extra information.
> It should not be called "unwind" since it is different than the old thing. I would be supportive of "resume_unwind" or something like that though.
For what it's worth, it serves exactly the same purpose as the old thing, except actually possible to reliably implement.
More information about the llvm-dev