[LLVMdev] LLVMdev Digest, Vol 85, Issue 50

Chris Lattner clattner at apple.com
Wed Jul 27 12:46:07 PDT 2011

On Jul 27, 2011, at 11:31 AM, John McCall wrote:

>>> I would be fine with still calling resume "unwind", but the new instruction
>>> does need to carry extra information.
>> It should not be called "unwind" since it is different than the old thing.  I would be supportive of "resume_unwind" or something like that though.
> For what it's worth, it serves exactly the same purpose as the old thing, except actually possible to reliably implement.

The documented semantics of the old thing was that it "starts a new unwinding process".  The new thing is much more reasonably a "resume an inflight unwinding process".


More information about the llvm-dev mailing list