[PATCH] D16723: [AMDGPU] Disassembler: Added basic disassembler for AMDGPU target.

Sam Kolton via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 1 21:10:15 PST 2016

SamWot added inline comments.

Comment at: lib/Target/AMDGPU/AMDGPU.td:306
@@ -305,2 +305,3 @@
   let guessInstructionProperties = 1;
+  let decodePositionallyEncodedOperands = 1;
   let noNamedPositionallyEncodedOperands = 1;
arsenm wrote:
> tstellarAMD wrote:
> > We should fix these name mismatches rather than enabling this bit.  It is much safer to use the name based matching.
> I think we should change the names to vdst. The way it is now I think follows the names of the operands as they appear in the ISA documentation, but the document isn't perfectly consistent. This is because a few instructions have a second sdst
Problem here is that renaming to vdst will affect all patterns that match this type of instructions. Also I'm not sure if this is realy needed because LLVM will still match operands positionalybut with help of operand names.


More information about the llvm-commits mailing list